Sax on the Web Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
Does anyone else have this problem and is it common or is something wrong with me or my sax. Sometimes when i play into the second octave (with the octave key) it produces the most horrible sounds, flying up into whistles or warbling in the worse fashion, so i loosen the neck, jiggle it a bit and then tighten it again and it all plays ok again. Why would this be??

thanks
 

·
Distinguished SOTW Member
Joined
·
2,487 Posts
check that both octave pips seal and vent properly, if you mean octave key as in with the neck vent open then it may be that the secondary vent is not closing properly, and just check high up the sax for any leaks.
 

·
Distinguished Technician & SOTW Columnist. RIP, Yo
Joined
·
17,204 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #4
wow really complicated, well i looked at the mechanism and everything SEEMS to be working ok. Just really sounds like sh*t sometimes, but then when i jiggle everything it seems to work ok again. I will see my tech in about 2 weeks time for a check up so i hope he finds the problem. Maybe it's just me....

thanks for the help
 

·
Distinguished SOTW Member, Forum Contributor 2009
Joined
·
3,204 Posts
one other thought : if it's an old sax, it might be that the neck is not sealing completely. When "wiggling", be sure you only turn the neck around, not wiggle it back and forth. That way there will be a space between the neck and the body, and that's bound to give problems too.
 
1 - 5 of 5 Posts
Top